<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="pingback" href="https://japan-forward.com/xmlrpc.php" />
<meta property="og:type" content="article" />
					<meta property="og:image" content="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-1000x600.jpg" />
		<meta name="twitter:image" content="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-1000x600.jpg" />
	<meta property="og:url" content="https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/" />
<meta property="og:title" content="BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama" />
<meta property="og:description" content="The 25-year-old swingman scored 27 points in Game 1 and did it again in Game 3 to help the Golden Kings reach the B. League playoff semifinals." />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/">
<meta name="twitter:title" content="BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama">
<meta name="twitter:description" content="The 25-year-old swingman scored 27 points in Game 1 and did it again in Game 3 to help the Golden Kings reach the B. League playoff semifinals.">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="theme-color" content="#ffffff">
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-88762595-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-88762595-1');
</script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NK56S3N');</script>
<!-- End Google Tag Manager -->
<title>BASKETBALL | Ryukyu&#039;s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama | JAPAN Forward</title>

<!-- All In One SEO Pack 3.7.1[2796,2924] -->
<meta name="description"  content="The 25-year-old swingman scored 27 points in Game 1 and did it again in Game 3 to help the Golden Kings reach the B. League playoff semifinals." />

<meta name="keywords"  content="ed odeven,b. league,basketball,ryukyu golden kings,keita imamura,keith richardson,toyama grouses,chiba jets,niigata albirex bb,steph curry,,sports" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://japan-forward.com/#organization","url":"https://japan-forward.com/","name":"JAPAN Forward","sameAs":["https://www.facebook.com/japanforward/","https://twitter.com/itsjapanforward/","https://instagram.com/japanforward/","https://www.youtube.com/japan-forward"],"logo":{"@type":"ImageObject","@id":"https://japan-forward.com/#logo","url":"https://japan-forward.com/wp-content/uploads/2019/05/logo_square.jpg","caption":""},"image":{"@id":"https://japan-forward.com/#logo"}},{"@type":"WebSite","@id":"https://japan-forward.com/#website","url":"https://japan-forward.com/","name":"JAPAN Forward","publisher":{"@id":"https://japan-forward.com/#organization"}},{"@type":"WebPage","@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#webpage","url":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/","inLanguage":"en-US","name":"BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama","isPartOf":{"@id":"https://japan-forward.com/#website"},"breadcrumb":{"@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#breadcrumblist"},"description":"The 25-year-old swingman scored 27 points in Game 1 and did it again in Game 3 to help the Golden Kings reach the B. League playoff semifinals.","image":{"@type":"ImageObject","@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#primaryimage","url":"https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-scaled-e1621416994943.jpg","width":1500,"height":1326},"primaryImageOfPage":{"@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#primaryimage"},"datePublished":"2021-05-22T02:20:42+09:00","dateModified":"2021-05-22T00:40:11+09:00"},{"@type":"Article","@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#article","isPartOf":{"@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#webpage"},"author":{"@id":"https://japan-forward.com/author/ed-odeven/#author"},"headline":"BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama","datePublished":"2021-05-22T02:20:42+09:00","dateModified":"2021-05-22T00:40:11+09:00","commentCount":0,"mainEntityOfPage":{"@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#webpage"},"publisher":{"@id":"https://japan-forward.com/#organization"},"articleSection":"Sports, B. League, basketball, Chiba Jets, Ed Odeven, Keita Imamura, Keith Richardson, Niigata Albirex BB, Ryukyu Golden Kings, steph curry, Toyama Grouses, Ed Odeven","image":{"@type":"ImageObject","@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#primaryimage","url":"https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-scaled-e1621416994943.jpg","width":1500,"height":1326}},{"@type":"Person","@id":"https://japan-forward.com/author/ed-odeven/#author","name":"Ed Odeven","sameAs":["https://m.facebook.com/Ed-Odeven-Reporting-622578864548599/?ref=bookmarks","https://twitter.com/ed_odeven"],"image":{"@type":"ImageObject","@id":"https://japan-forward.com/#personlogo","url":"https://japan-forward.com/wp-content/uploads/2020/05/ed-odeven-japan-forward.jpg","width":96,"height":96,"caption":"Ed Odeven"}},{"@type":"BreadcrumbList","@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://japan-forward.com/","url":"https://japan-forward.com/","name":"JAPAN Forward - REAL ISSUES, REAL VOICES, REAL JAPAN. "}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/","url":"https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/","name":"BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama"}}]}]}</script>
<link rel="canonical" href="https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="BASKETBALL | Ryukyu&#039;s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama | JAPAN Forward" />
<meta property="og:description" content="The 25-year-old swingman scored 27 points in Game 1 and did it again in Game 3 to help the Golden Kings reach the B. League playoff semifinals." />
<meta property="og:url" content="https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/" />
<meta property="og:site_name" content="JAPAN Forward" />
<meta property="og:image" content="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-1024x905.jpg" />
<meta property="fb:admins" content="1182128755219778" />
<meta property="fb:app_id" content="177741436087957" />
<meta property="article:tag" content="ed odeven" />
<meta property="article:tag" content="b. league" />
<meta property="article:tag" content="basketball" />
<meta property="article:tag" content="ryukyu golden kings" />
<meta property="article:tag" content="keita imamura" />
<meta property="article:tag" content="keith richardson" />
<meta property="article:tag" content="toyama grouses" />
<meta property="article:tag" content="chiba jets" />
<meta property="article:tag" content="niigata albirex bb" />
<meta property="article:tag" content="steph curry" />
<meta property="article:tag" content="" />
<meta property="article:tag" content="sports" />
<meta property="article:published_time" content="2021-05-22T02:20:42Z" />
<meta property="article:modified_time" content="2021-05-22T00:40:11Z" />
<meta property="og:image:secure_url" content="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-1024x905.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@itsjapanforward" />
<meta name="twitter:creator" content="@ed_odeven" />
<meta name="twitter:domain" content="https://japan-forward.com/" />
<meta name="twitter:title" content="BASKETBALL | Ryukyu&#039;s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama | JAPAN Forward" />
<meta name="twitter:description" content="The 25-year-old swingman scored 27 points in Game 1 and did it again in Game 3 to help the Golden Kings reach the B. League playoff semifinals." />
<meta name="twitter:image" content="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-1024x905.jpg" />
<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/japan-forward.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- japan-forward.com is managing ads with Advanced Ads – https://wpadvancedads.com/ --><script data-wpfc-render="false">
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://japan-forward.com/wp-includes/css/dist/block-library/style.min.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-vendors-style-css'  href='https://japan-forward.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/vendors-style.css?ver=3.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://japan-forward.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css?ver=3.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://japan-forward.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='nextend_fb_connect_stylesheet-css'  href='https://japan-forward.com/wp-content/plugins/nextend-facebook-connect/buttons/facebook-btn.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://japan-forward.com/wp-content/plugins/theia-post-slider-premium/dist/css/font-theme.css?ver=2.6.0' type='text/css' media='all' />
<style id='theiaPostSlider-inline-css' type='text/css'>


				.theiaPostSlider_nav.fontTheme ._title,
				.theiaPostSlider_nav.fontTheme ._text {
					line-height: 48px;
				}

				.theiaPostSlider_nav.fontTheme ._button,
				.theiaPostSlider_nav.fontTheme ._button svg {
					color: #d12d26;
					fill: #d12d26;
				}

				.theiaPostSlider_nav.fontTheme ._button ._2 span {
					font-size: 48px;
					line-height: 48px;
				}

				.theiaPostSlider_nav.fontTheme ._button ._2 svg {
					width: 48px;
				}

				.theiaPostSlider_nav.fontTheme ._button:hover,
				.theiaPostSlider_nav.fontTheme ._button:focus,
				.theiaPostSlider_nav.fontTheme ._button:hover svg,
				.theiaPostSlider_nav.fontTheme ._button:focus svg {
					color: #e0605b;
					fill: #e0605b;
				}

				.theiaPostSlider_nav.fontTheme ._disabled,
                .theiaPostSlider_nav.fontTheme ._disabled svg {
					color: #7a7a7a !important;
					fill: #7a7a7a !important;
				}
			
</style>
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://japan-forward.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=4.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://japan-forward.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=4.8.0' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://japan-forward.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=4.8.0' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='wpos-slick-style-css'  href='https://japan-forward.com/wp-content/plugins/wp-slick-slider-and-image-carousel/assets/css/slick.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpsisac-public-style-css'  href='https://japan-forward.com/wp-content/plugins/wp-slick-slider-and-image-carousel/assets/css/slick-slider-style.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css'  href='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://japan-forward.com/wp-includes/css/dashicons.min.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css'  href='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://japan-forward.com/wp-content/themes/zox-news/style.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://japan-forward.com/wp-content/themes/zox-news-japanforward/style.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css'  href='https://japan-forward.com/wp-content/themes/zox-news-japanforward/style.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://japan-forward.com/wp-content/themes/zox-news/css/reset.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://japan-forward.com/wp-content/themes/zox-news-japanforward/font-awesome/css/font-awesome.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C700%2C900%7COswald%3A400%2C700%7CAdvent+Pro%3A700%7COpen+Sans%3A700%7CAnton%3A400Oswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CPT+Serif%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://japan-forward.com/wp-content/themes/zox-news/css/media-queries.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link rel='stylesheet' id='aurora-heatmap-css'  href='https://japan-forward.com/wp-content/plugins/aurora-heatmap/style.css?ver=1.4.9' type='text/css' media='all' />
<script type='text/javascript' src='https://japan-forward.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/aurora-heatmap/js/mobile-detect.min.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='mobile-detect-js'></script>
<script type='text/javascript' id='aurora-heatmap-reporter-js-extra'>
/* <![CDATA[ */
var aurora_heatmap_reporter = {"ajax_url":"https:\/\/japan-forward.com\/wp-admin\/admin-ajax.php","action":"aurora_heatmap","interval":"10","stacks":"10","reports":"click_pc,click_mobile","debug":"0","ajax_delay_time":"3000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/aurora-heatmap/js/reporter.js?ver=1.4.9' id='aurora-heatmap-reporter-js'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://japan-forward.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://japan-forward.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='[Bookmark] Jamaica-Born Japan Soccer Star Musashi Suzuki Reveals Racist Abuse' href='https://japan-forward.com/bookmark-jamaica-born-japan-soccer-star-musashi-suzuki-reveals-racist-abuse/' />

<link rel='shortlink' href='https://japan-forward.com/?p=71044' />
<link rel="alternate" type="application/json+oembed" href="https://japan-forward.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjapan-forward.com%2Fbasketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://japan-forward.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjapan-forward.com%2Fbasketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama%2F&#038;format=xml" />
<style>:root {
			--lazy-loader-animation-duration: 300ms;
		}
		  
		.lazyload {
	display: block;
}

.lazyload,
        .lazyloading {
			opacity: 0;
		}


		.lazyloaded {
			opacity: 1;
			transition: opacity 300ms;
			transition: opacity var(--lazy-loader-animation-duration);
		}</style><noscript><style>.lazyload { display: none; } .lazyload[class*="lazy-loader-background-element-"] { display: block; opacity: 1; }</style></noscript><script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
    <script type="text/javascript">
        var ajaxurl = 'https://japan-forward.com/wp-admin/admin-ajax.php';
    </script>
            <style>
            #tps_carousel_container ._button,
            #tps_carousel_container ._button svg {
                color: #f08100;
                fill: #f08100;
            }

            #tps_carousel_container ._button {
                font-size: 32px;
                line-height: 32px;
            }

            #tps_carousel_container ._button svg {
                width: 32px;
                height: 32px;
            }

            #tps_carousel_container ._button:hover,
            #tps_carousel_container ._button:focus,
            #tps_carousel_container ._button:hover svg,
            #tps_carousel_container ._button:focus svg {
                color: #ffa338;
                fill: #ffa338;
            }

            #tps_carousel_container ._disabled,
            #tps_carousel_container ._disabled svg {
                color: #777777 !important;
                fill: #777777 !important;
            }

            #tps_carousel_container ._carousel {
                margin: 0 42px;
            }

            #tps_carousel_container ._prev {
                margin-right: 10px;
            }

            #tps_carousel_container ._next {
                margin-left: 10px;
            }
        </style>
        <style type="text/css">/* Mailchimp for WP - Checkbox Styles */
.mc4wp-checkbox-contact-form-7 {
  clear: both;
  display: block;
  position: static;
  width: auto; }
  .mc4wp-checkbox-contact-form-7 input {
    float: none;
    width: auto;
    position: static;
    margin: 0 6px 0 0;
    padding: 0;
    vertical-align: middle;
    display: inline-block !important;
    max-width: 21px;
    -webkit-appearance: checkbox; }
  .mc4wp-checkbox-contact-form-7 label {
    float: none;
    display: block;
    cursor: pointer;
    width: auto;
    position: static;
    margin: 0 0 16px 0; }
</style>	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	
<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '1939916709605054', {}, {
    "agent": "wordpress-5.5.5-3.0.5"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=1939916709605054&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<link rel="amphtml" href="https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/amp/"><script data-ad-client="ca-pub-8676439269371289" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.
Click the help icon above to learn more.
*/
a.pages-btn{
background:#e40012;
color:#fff !important;
padding:10px 20px;
border-radius:4px;
display:block;
text-align:center;
max-width:400px;
margin:auto;
}
.gallery-caption {
display: -webkit-box;
-webkit-line-clamp: 10;
-webkit-box-orient: vertical;
overflow: hidden; 
}
@media screen and (max-width: 767px){
.gallery-caption {
-webkit-line-clamp: 3;
}
}
span.wpcf7-list-item { display: block; font-weight: normal }
.wpcf7
{
font-weight: bold;
}
.boxfeature { 
padding:5px 6px;
color:#000;
background-color:#efefef;
border:5px solid #b3d9ee
}



		</style>
		</head>
<body class="post-template-default single single-post postid-71044 single-format-standard theme-zox-news theiaPostSlider_body woocommerce-no-js aa-prefix-jf-">
        <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NK56S3N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="https://japan-forward.com/"><img src="https://japan-forward.com/wp-content/uploads/2020/11/japan_forward_logo-box-top.png" alt="JAPAN Forward" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-fly-out-all-container"><ul id="menu-fly-out-all" class="menu"><li id="menu-item-57784" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57784"><a href="https://japan-forward.com/about-japan-forward-jp/supporter/">会員について</a></li>
<li id="menu-item-58207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58207"><a href="https://japan-forward.com/japanese/">日本語記事</a></li>
<li id="menu-item-54281" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54281"><a href="https://japan-forward.com/my-account/">My account</a></li>
<li id="menu-item-54330" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54330"><a href="https://japan-forward.com/tag/editors-pick/">Editor&#8217;s Pick</a></li>
<li id="menu-item-54266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54266"><a href="https://japan-forward.com/category/politics-security/">Politics &amp; Security</a></li>
<li id="menu-item-54269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54269"><a href="https://japan-forward.com/category/economy-tech/">Economy &amp; Tech</a></li>
<li id="menu-item-54265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54265"><a href="https://japan-forward.com/category/culture/">Culture</a>
<ul class="sub-menu">
	<li id="menu-item-54612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54612"><a href="https://japan-forward.com/tag/rakugo/">Rakugo</a></li>
	<li id="menu-item-54285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54285"><a href="https://japan-forward.com/category/travel/food/">Food</a></li>
	<li id="menu-item-54274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54274"><a href="https://japan-forward.com/category/books/">Books</a></li>
</ul>
</li>
<li id="menu-item-54267" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54267"><a href="https://japan-forward.com/category/special-report/">Special Reports</a>
<ul class="sub-menu">
	<li id="menu-item-54268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54268"><a href="https://japan-forward.com/category/coronavirus-news-alert/">Coronavirus</a></li>
	<li id="menu-item-54276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54276"><a href="https://japan-forward.com/category/special-report/mythbusters/">Mythbusters</a></li>
	<li id="menu-item-54275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54275"><a href="https://japan-forward.com/category/culture/japanese-sword-column/">The Japanese Sword Column</a></li>
	<li id="menu-item-54277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54277"><a href="https://japan-forward.com/category/culture/soul-of-japan/">Soul of Japan</a></li>
	<li id="menu-item-54272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54272"><a href="https://japan-forward.com/category/special-report/north-korean-abduction/">Abducted: The Japanese Kidnapped by North Korea</a></li>
</ul>
</li>
<li id="menu-item-54270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54270"><a href="https://japan-forward.com/category/blog/">Blog</a>
<ul class="sub-menu">
	<li id="menu-item-54273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54273"><a href="https://japan-forward.com/category/blog/hidden-wonders/">Hidden Wonders</a></li>
</ul>
</li>
<li id="menu-item-54271" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-54271"><a href="https://japan-forward.com/category/sports/">Sports</a></li>
<li id="menu-item-54279" class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-54279"><a href="https://japan-forward.com/product/product-category/contribute/">Contribute</a></li>
<li id="menu-item-54280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54280"><a href="https://japan-forward.com/subscribe-to-podcast/">Subscribe to Podcast</a></li>
<li id="menu-item-54441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54441"><a href="https://japan-forward.com/jplogin0211">Log in</a></li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/japanforward" target="_blank" class="fa fa-facebook fa-2"></a></li>
										<li><a href="https://www.twitter.com/itsjapanforward" target="_blank" class="fa fa-twitter fa-2"></a></li>
													<li><a href="https://www.instagram.com/japanforward" target="_blank" class="fa fa-instagram fa-2"></a></li>
													<li><a href="https://www.youtube.com/japan-forward" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
										<li><a href="https://www.linkedin.com/company/japan-forward/" target="_blank" class="fa fa-linkedin fa-2"></a></li>
								</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->	<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="https://japan-forward.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
				<div id="mvp-site-wall" class="left relative">
											<div id="mvp-leader-wrap">
					<div align="center"><span class="mvp-ad-label">Advertisement</span></div>

<script type="text/javascript">
var loadIMG = [
"https://japan-forward.com/wp-content/uploads/2021/01/tokyo-wfh-hero-2.jpg' alt=\"Tokyo During COVID-19: Green Space, Rise of Telework Bring New Lifestyle Opportunities\" width=\"100%\" onload=\"gtag('event', 'impression', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-hero-2'});\"",
"https://japan-forward.com/wp-content/uploads/2021/01/tokyo-wfh-hero-3.jpg' alt=\"Tokyo During COVID-19: Green Space, Rise of Telework Bring New Lifestyle Opportunities\" width=\"100%\"  onload=\"gtag('event', 'impression', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-hero-3'});\"",
"https://japan-forward.com/wp-content/uploads/2021/03/3-11-earthquake-rebuilding-10-years-later-tohokus-recovery-and-resilience-together-with-the-world-hero.jpg' alt=\"[3.11 Earthquake: Rebuilding] 10 Years Later: Tohoku’s Recovery and Resilience Together with the World\" width=\"100%\"  onload=\"gtag('event', 'impression', {'event_category': 'banner','event_label': '3-11-mofa-hero'});\"",
"https://japan-forward.com/wp-content/uploads/2021/03/innovators-in-japan-are-developing-new-technologies-to-counter-coronavirus-hero.jpg' alt=\"Innovators in Japan are Developing New Technologies to Counter Coronavirus\" width=\"100%\"  onload=\"gtag('event', 'impression', {'event_category': 'banner','event_label': 'innovators-mofa-hero'});\"",
];

var loadURL = [
"https://japan-forward.com/tokyo-during-covid-19-green-space-rise-of-telework-bring-new-lifestyle-opportunities' target=\"_blank\" onclick=\"gtag('event', 'click', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-hero-2'});\"",
"https://japan-forward.com/tokyo-during-covid-19-green-space-rise-of-telework-bring-new-lifestyle-opportunities' target=\"_blank\"  onclick=\"gtag('event', 'click', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-hero-3'});\"",
"https://japan-forward.com/3-11-earthquake-rebuilding-10-years-later-tohokus-recovery-and-resilience-together-with-the-world' target=\"_blank\"  onclick=\"gtag('event', 'click', {'event_category': 'banner','event_label': '3-11-mofa-hero'});\"",
"https://japan-forward.com/innovators-in-japan-are-developing-new-technologies-to-counter-coronavirus/' target=\"_blank\"  onclick=\"gtag('event', 'click', {'event_category': 'banner','event_label': 'innovators-mofa-hero'});\"",
];

var rnd = Math.floor(Math.random()*loadIMG.length);
 document.write("<a href='"+loadURL[rnd]+"'>");
 document.write("<img src='"+loadIMG[rnd]+"'>");

</script>
<noscript>

<a href="https://japan-forward.com/tokyo-during-covid-19-green-space-rise-of-telework-bring-new-lifestyle-opportunities/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-hero-3'});">
<img src="https://japan-forward.com/wp-content/uploads/2021/01/tokyo-wfh-hero-3.jpg" alt="Tokyo During COVID-19: Green Space, Rise of Telework Bring New Lifestyle Opportunities" width="100%" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-hero-3'});"></a></div>
</noscript>				</div><!--mvp-leader-wrap-->
										<div id="mvp-site-main" class="left relative">
			<header id="mvp-main-head-wrap" class="left relative">
									<nav id="mvp-main-nav-wrap" class="left relative">
						<div id="mvp-main-nav-top" class="left relative">
							<div class="mvp-main-box">
								<div id="mvp-nav-top-wrap" class="left relative">
									<div class="mvp-nav-top-right-out left relative">
										<div class="mvp-nav-top-right-in">
											<div class="mvp-nav-top-cont left relative">
												<div class="mvp-nav-top-left-out relative">
													<div class="mvp-nav-top-left">
														<div class="mvp-nav-soc-wrap">
																															<a href="https://www.facebook.com/japanforward" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook fa-2"></span></a>
																																														<a href="https://www.twitter.com/itsjapanforward" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																																														<a href="https://www.instagram.com/japanforward" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a>
																																														<a href="https://www.youtube.com/japan-forward" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube-play fa-2"></span></a>
																													</div><!--mvp-nav-soc-wrap-->
														<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
															<span></span>
															<span></span>
															<span></span>
															<span></span>
														</div><!--mvp-fly-but-wrap-->
													</div><!--mvp-nav-top-left-->
													<div class="mvp-nav-top-left-in">
														<div class="mvp-nav-top-mid left relative" itemscope itemtype="http://schema.org/Organization">
																															<a class="mvp-nav-logo-reg" itemprop="url" href="https://japan-forward.com/"><img itemprop="logo" src="https://japan-forward.com/wp-content/uploads/2020/11/japan_forward_logo-box-top.png" alt="JAPAN Forward" data-rjs="2" /></a>
																																														<a class="mvp-nav-logo-small" href="https://japan-forward.com/"><img src="https://japan-forward.com/wp-content/uploads/2020/11/japan_forward_logo-box-top.png" alt="JAPAN Forward" data-rjs="2" /></a>
																																														<h2 class="mvp-logo-title">JAPAN Forward</h2>
																																														<div class="mvp-drop-nav-title left">
																	<h4>BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama</h4>
																</div><!--mvp-drop-nav-title-->
																													</div><!--mvp-nav-top-mid-->
													</div><!--mvp-nav-top-left-in-->
												</div><!--mvp-nav-top-left-out-->
											</div><!--mvp-nav-top-cont-->
										</div><!--mvp-nav-top-right-in-->
										<div class="mvp-nav-top-right">
																							<div class="mvp-woo-cart-wrap">
													<a class="mvp-woo-cart" href="https://japan-forward.com/cart/" title="View your shopping cart"><span class="mvp-woo-cart-num">0</span></a><span class="mvp-woo-cart-icon fa fa-shopping-cart" aria-hidden="true"></span>
												</div><!--mvp-woo-cart-wrap-->
																						<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
										</div><!--mvp-nav-top-right-->
									</div><!--mvp-nav-top-right-out-->
								</div><!--mvp-nav-top-wrap-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-top-->
						<div id="mvp-main-nav-bot" class="left relative">
							<div id="mvp-main-nav-bot-cont" class="left">
								<div class="mvp-main-box">
									<div id="mvp-nav-bot-wrap" class="left">
										<div class="mvp-nav-bot-right-out left">
											<div class="mvp-nav-bot-right-in">
												<div class="mvp-nav-bot-cont left">
													<div class="mvp-nav-bot-left-out">
														<div class="mvp-nav-bot-left left relative">
															<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
																<span></span>
																<span></span>
																<span></span>
																<span></span>
															</div><!--mvp-fly-but-wrap-->
														</div><!--mvp-nav-bot-left-->
														<div class="mvp-nav-bot-left-in">
															<div class="mvp-nav-menu left">
																<div class="menu-2020-top-menu-container"><ul id="menu-2020-top-menu" class="menu"><li id="menu-item-54257" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54257"><a href="https://japan-forward.com/category/politics-security/">Politics &amp; Security</a></li>
<li id="menu-item-54329" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54329"><a href="https://japan-forward.com/tag/editors-pick/">Editor&#8217;s Pick</a></li>
<li id="menu-item-54263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54263"><a href="https://japan-forward.com/category/coronavirus-news-alert/">Coronavirus</a></li>
<li id="menu-item-54261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54261"><a href="https://japan-forward.com/category/economy-tech/">Economy &amp; Tech</a></li>
<li id="menu-item-54262" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54262"><a href="https://japan-forward.com/category/culture/">Culture</a>
<ul class="sub-menu">
	<li id="menu-item-61847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61847"><a href="https://japan-forward.com/category/sakura/">Sakura 🌸</a></li>
	<li id="menu-item-54611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54611"><a href="https://japan-forward.com/tag/rakugo/">Rakugo</a></li>
	<li id="menu-item-61133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61133"><a href="https://japan-forward.com/category/culture/japanese-sword-column/">The Japanese Sword Column</a></li>
	<li id="menu-item-61131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61131"><a href="https://japan-forward.com/category/culture/history/">History</a></li>
	<li id="menu-item-61132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61132"><a href="https://japan-forward.com/category/culture/soul-of-japan/">Soul of Japan</a></li>
</ul>
</li>
<li id="menu-item-54259" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-54259"><a href="https://japan-forward.com/category/sports/">Sports</a></li>
<li id="menu-item-54258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54258"><a href="https://japan-forward.com/category/special-report/">Special Reports</a>
<ul class="sub-menu">
	<li id="menu-item-61135" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61135"><a href="https://japan-forward.com/category/special-report/north-korean-abduction/">Abducted: The Japanese Kidnapped by North Korea</a></li>
	<li id="menu-item-61139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61139"><a href="https://japan-forward.com/category/special-report/remembering-311/">Remembering 3/11</a></li>
	<li id="menu-item-61137" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61137"><a href="https://japan-forward.com/category/special-report/mythbusters/">Mythbusters</a></li>
	<li id="menu-item-61136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61136"><a href="https://japan-forward.com/category/special-report/japan-enters-a-new-era/">Japan Enters a New Era</a></li>
</ul>
</li>
<li id="menu-item-54260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54260"><a href="https://japan-forward.com/category/blog/">Blog</a></li>
<li id="menu-item-54282" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54282"><a href="https://japan-forward.com/category/podcast/">Podcast</a>
<ul class="sub-menu">
	<li id="menu-item-61365" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61365"><a href="https://japan-forward.com/tag/real-issues-real-voices-real-japan/">Real Issues, Real Voices, Real Japan</a></li>
	<li id="menu-item-62796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62796"><a href="https://japan-forward.com/category/podcast/sports-talk-podcast/">Sports Talk</a></li>
	<li id="menu-item-61140" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61140"><a target="_blank" rel="noopener noreferrer" href="https://soundcloud.com/user-983930015">Ice Time</a></li>
</ul>
</li>
<li id="menu-item-54264" class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-54264"><a href="https://japan-forward.com/product/product-category/contribute/">Contribute</a></li>
<li id="menu-item-58181" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58181"><a href="/japanese/">日本語記事</a></li>
</ul></div>															</div><!--mvp-nav-menu-->
														</div><!--mvp-nav-bot-left-in-->
													</div><!--mvp-nav-bot-left-out-->
												</div><!--mvp-nav-bot-cont-->
											</div><!--mvp-nav-bot-right-in-->
											<div class="mvp-nav-bot-right left relative">
												<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
											</div><!--mvp-nav-bot-right-->
										</div><!--mvp-nav-bot-right-out-->
									</div><!--mvp-nav-bot-wrap-->
								</div><!--mvp-main-nav-bot-cont-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-bot-->
					</nav><!--mvp-main-nav-wrap-->
							</header><!--mvp-main-head-wrap-->
			<div id="mvp-main-body-wrap" class="left relative">
	<div class="mvp-main-box">
<div class="mvp-auto-post-grid">
	<div class="mvp-alp-side">
		<div class="mvp-alp-side-in">
			<div class="alp-related-posts-wrapper">
	<div class="alp-related-posts">
				<div class="alp-related-post post-71044 current" data-id="71044" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://japan-forward.com/category/sports/">Sports</a>
										</p>
				<a class="post-title" href="https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/">BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama</a>
			</div>
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/&amp;t=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama &amp;url=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-590x354.jpg&amp;description=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
					</div>
					<div class="alp-advert">
							</div>
				<div class="alp-related-post post-70802 " data-id="70802" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://japan-forward.com/category/culture/">Culture</a>
													<a class="post-category" href="https://japan-forward.com/category/sports/">Sports</a>
										</p>
				<a class="post-title" href="https://japan-forward.com/bookmark-jamaica-born-japan-soccer-star-musashi-suzuki-reveals-racist-abuse/">[Bookmark] Jamaica-Born Japan Soccer Star Musashi Suzuki Reveals Racist Abuse</a>
			</div>
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/bookmark-jamaica-born-japan-soccer-star-musashi-suzuki-reveals-racist-abuse/&amp;t=[Bookmark] Jamaica-Born Japan Soccer Star Musashi Suzuki Reveals Racist Abuse', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=[Bookmark] Jamaica-Born Japan Soccer Star Musashi Suzuki Reveals Racist Abuse &amp;url=https://japan-forward.com/bookmark-jamaica-born-japan-soccer-star-musashi-suzuki-reveals-racist-abuse/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/bookmark-jamaica-born-japan-soccer-star-musashi-suzuki-reveals-racist-abuse/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/Soccer-Musashi-Suzuki-012-590x354.jpg&amp;description=[Bookmark] Jamaica-Born Japan Soccer Star Musashi Suzuki Reveals Racist Abuse', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=[Bookmark] Jamaica-Born Japan Soccer Star Musashi Suzuki Reveals Racist Abuse&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/bookmark-jamaica-born-japan-soccer-star-musashi-suzuki-reveals-racist-abuse/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
					</div>
				<div class="alp-related-post post-70869 " data-id="70869" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://japan-forward.com/category/sports/">Sports</a>
										</p>
				<a class="post-title" href="https://japan-forward.com/odds-and-evens-reigning-indy-500-champion-takuma-sato-chases-history-in-pursuit-of-another-title/">[ODDS and EVENS] Reigning Indy 500 Champion Takuma Sato Chases History in Pursuit of Another Title</a>
			</div>
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/odds-and-evens-reigning-indy-500-champion-takuma-sato-chases-history-in-pursuit-of-another-title/&amp;t=[ODDS and EVENS] Reigning Indy 500 Champion Takuma Sato Chases History in Pursuit of Another Title', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=[ODDS and EVENS] Reigning Indy 500 Champion Takuma Sato Chases History in Pursuit of Another Title &amp;url=https://japan-forward.com/odds-and-evens-reigning-indy-500-champion-takuma-sato-chases-history-in-pursuit-of-another-title/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/odds-and-evens-reigning-indy-500-champion-takuma-sato-chases-history-in-pursuit-of-another-title/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/Indy3-590x354.jpg&amp;description=[ODDS and EVENS] Reigning Indy 500 Champion Takuma Sato Chases History in Pursuit of Another Title', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=[ODDS and EVENS] Reigning Indy 500 Champion Takuma Sato Chases History in Pursuit of Another Title&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/odds-and-evens-reigning-indy-500-champion-takuma-sato-chases-history-in-pursuit-of-another-title/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
					</div>
				<div class="alp-related-post post-70824 " data-id="70824" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://japan-forward.com/category/culture/">Culture</a>
													<a class="post-category" href="https://japan-forward.com/category/sports/tokyo2020/">Tokyo 2020</a>
										</p>
				<a class="post-title" href="https://japan-forward.com/manga-artist-shin-yamada-spotlights-the-tokyo-olympics-dilemma/">Manga Artist Shin Yamada Spotlights the Tokyo Olympics Dilemma</a>
			</div>
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/manga-artist-shin-yamada-spotlights-the-tokyo-olympics-dilemma/&amp;t=Manga Artist Shin Yamada Spotlights the Tokyo Olympics Dilemma', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=Manga Artist Shin Yamada Spotlights the Tokyo Olympics Dilemma &amp;url=https://japan-forward.com/manga-artist-shin-yamada-spotlights-the-tokyo-olympics-dilemma/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/manga-artist-shin-yamada-spotlights-the-tokyo-olympics-dilemma/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/Shin-Yamada-Manga-Sankei-Shimbun-IOC-May-12-2021-590x354.jpg&amp;description=Manga Artist Shin Yamada Spotlights the Tokyo Olympics Dilemma', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=Manga Artist Shin Yamada Spotlights the Tokyo Olympics Dilemma&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/manga-artist-shin-yamada-spotlights-the-tokyo-olympics-dilemma/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
					</div>
				<div class="alp-related-post post-70766 " data-id="70766" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://japan-forward.com/category/sports/">Sports</a>
										</p>
				<a class="post-title" href="https://japan-forward.com/horse-racing-gran-alegria-dominates-down-the-stretch-for-runaway-victory-in-victoria-mile/">HORSE RACING | Gran Alegria Dominates Down the Stretch for Runaway Victory in Victoria Mile</a>
			</div>
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/horse-racing-gran-alegria-dominates-down-the-stretch-for-runaway-victory-in-victoria-mile/&amp;t=HORSE RACING | Gran Alegria Dominates Down the Stretch for Runaway Victory in Victoria Mile', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=HORSE RACING | Gran Alegria Dominates Down the Stretch for Runaway Victory in Victoria Mile &amp;url=https://japan-forward.com/horse-racing-gran-alegria-dominates-down-the-stretch-for-runaway-victory-in-victoria-mile/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/horse-racing-gran-alegria-dominates-down-the-stretch-for-runaway-victory-in-victoria-mile/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/CL.516-590x354.jpg&amp;description=HORSE RACING | Gran Alegria Dominates Down the Stretch for Runaway Victory in Victoria Mile', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=HORSE RACING | Gran Alegria Dominates Down the Stretch for Runaway Victory in Victoria Mile&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/horse-racing-gran-alegria-dominates-down-the-stretch-for-runaway-victory-in-victoria-mile/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
					</div>
				<div class="alp-related-post post-70643 " data-id="70643" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://japan-forward.com/category/sports/">Sports</a>
										</p>
				<a class="post-title" href="https://japan-forward.com/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak/">[JAPAN SPORTS NOTEBOOK] Antlers End Marinos’ 11-Match Unbeaten Streak</a>
			</div>
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak/&amp;t=[JAPAN SPORTS NOTEBOOK] Antlers End Marinos’ 11-Match Unbeaten Streak', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=[JAPAN SPORTS NOTEBOOK] Antlers End Marinos’ 11-Match Unbeaten Streak &amp;url=https://japan-forward.com/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-590x354.jpg&amp;description=[JAPAN SPORTS NOTEBOOK] Antlers End Marinos’ 11-Match Unbeaten Streak', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=[JAPAN SPORTS NOTEBOOK] Antlers End Marinos’ 11-Match Unbeaten Streak&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
					</div>
				<div class="alp-related-post post-70547 " data-id="70547" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://japan-forward.com/category/sports/">Sports</a>
										</p>
				<a class="post-title" href="https://japan-forward.com/basketball-utsunomiya-brex-begin-quest-to-capture-b-league-title-as-playoffs-tip-off/">BASKETBALL | Utsunomiya Brex Begin Quest to Capture B. League Title as Playoffs Tip Off</a>
			</div>
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/basketball-utsunomiya-brex-begin-quest-to-capture-b-league-title-as-playoffs-tip-off/&amp;t=BASKETBALL | Utsunomiya Brex Begin Quest to Capture B. League Title as Playoffs Tip Off', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=BASKETBALL | Utsunomiya Brex Begin Quest to Capture B. League Title as Playoffs Tip Off &amp;url=https://japan-forward.com/basketball-utsunomiya-brex-begin-quest-to-capture-b-league-title-as-playoffs-tip-off/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/basketball-utsunomiya-brex-begin-quest-to-capture-b-league-title-as-playoffs-tip-off/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-590x354.jpg&amp;description=BASKETBALL | Utsunomiya Brex Begin Quest to Capture B. League Title as Playoffs Tip Off', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=BASKETBALL | Utsunomiya Brex Begin Quest to Capture B. League Title as Playoffs Tip Off&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/basketball-utsunomiya-brex-begin-quest-to-capture-b-league-title-as-playoffs-tip-off/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
					</div>
			</div><!--alp-related-posts-->
</div><!--alp-related-posts-wrapper-->		</div><!--mvp-alp-side-in-->
	</div><!--mvp-alp-side-->
	<div class="mvp-auto-post-main">
<article id="post-71044" class="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/"/>
		<div id="mvp-article-cont" class="left relative">
				<div id="mvp-post-main" class="left relative">
					<header id="mvp-post-head" class="left relative">
						<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://japan-forward.com/category/sports/"><span class="mvp-post-cat left">Sports</span></a></h3>
						<h1 class="mvp-post-title left entry-title" itemprop="headline">BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama</h1>
													<span class="mvp-post-excerpt left"><p>The 25-year-old swingman scored 27 points in Game 1 and did it again in Game 3 to help the Golden Kings reach the B. League playoff semifinals.</p>
</span>
																			<div class="mvp-author-info-wrap left relative">
								<div class="mvp-author-info-thumb left relative">
									<noscript><img src="https://japan-forward.com/wp-content/uploads/2020/05/ed-odeven-japan-forward-100x100.jpg" width="46" height="46" alt="Ed Odeven" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo"></noscript><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 46 46'%3E%3C/svg%3E" width="46" height="46" alt="Ed Odeven" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo lazyload" data-src="https://japan-forward.com/wp-content/uploads/2020/05/ed-odeven-japan-forward-100x100.jpg">								</div><!--mvp-author-info-thumb-->
								<div class="mvp-author-info-text left relative">
									<div class="mvp-author-info-date left relative">
										<p>Published</p> <span class="mvp-post-date">5 mins ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2021-05-22">May 22, 2021</time></span>
										<meta itemprop="dateModified" content="2021-05-22 9:40 am"/>
									</div><!--mvp-author-info-date-->
									<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
										<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://japan-forward.com/author/ed-odeven/" title="Posts by Ed Odeven" rel="author">Ed Odeven</a></span> <a href="https://twitter.com/ed_odeven" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>									</div><!--mvp-author-info-name-->
								</div><!--mvp-author-info-text-->
							</div><!--mvp-author-info-wrap-->
											</header>
							<div id="mvp-post-content" class="left relative">
																																						<div id="mvp-post-feat-img" class="left relative mvp-post-feat-img-wide2" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
												<noscript><img width="1500" height="1326" src="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-scaled-e1621416994943.jpg" class="attachment- size- wp-post-image" alt></noscript><img width="1500" height="1326" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1500 1326'%3E%3C/svg%3E" class="attachment- size- wp-post-image lazyload" alt data-src="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-scaled-e1621416994943.jpg">																								<meta itemprop="url" content="https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-1000x600.jpg">
												<meta itemprop="width" content="1000">
												<meta itemprop="height" content="600">
											</div><!--mvp-post-feat-img-->
																							<span class="mvp-feat-caption">Ryukyu Golden Kings swingman Keita Imamura provided a big offensive boost in the first round of the B. League playoffs against the Toyama Grouses. (B. League)</span>
																																																						<div id="mvp-content-wrap" class="left relative">
											<div id="mvp-content-body" class="left relative">
												<div id="mvp-content-body-top" class="left relative">
																																																										<div class="mvp-alp-soc-reg left relative">
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/&amp;t=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama &amp;url=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-590x354.jpg&amp;description=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
</div>
																																																							<div id="mvp-content-main" class="left relative">
														<div id="tps_slideContainer_71044" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">

<p class="has-text-align-center">~~</p><div class="jf-after-first-paragraph" id="jf-609299716"><div style="margin-bottom:8px;"><a href="https://japan-forward.com/tokyo-during-covid-19-green-space-rise-of-telework-bring-new-lifestyle-opportunities/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-banner-2'});">
<noscript><img src="https://japan-forward.com/wp-content/uploads/2021/01/tokyo-wfh-Top_C.jpg" alt="Tokyo During COVID-19: Green Space, Rise of Telework Bring New Lifestyle Opportunities" width="100%" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-banner-2'});"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Tokyo During COVID-19: Green Space, Rise of Telework Bring New Lifestyle Opportunities" width="100%" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-banner-2'});" data-src="https://japan-forward.com/wp-content/uploads/2021/01/tokyo-wfh-Top_C.jpg" class=" lazyload"></a></div></div>



<p>Veteran standouts dot the rosters of the Ryukyu Golden Kings and Toyama Grouses. But it&#8217;s not always the most well-known players who provide game-changing contributions.</p>



<p>Such was the case from May 15-17 in their B. League first-round playoff series at Okinawa Arena.</p>



<p>For the victorious Golden Kings, who defeated the Grouses 86-77 in Game 3 on Monday, May 17, the noteworthy performance of swingman Keita Imamura can&#8217;t be overstated. In fact, he was instrumental in both of the team&#8217;s hard-earned victories in the series.</p>



<p>In Game 1, he scored a season-high 27 points in 28-plus pulsating minutes off the bench, knocking down 5 of 10 3-point attempts and finishing 11-for-17 from the floor. He also grabbed five rebounds and made two steals. American forward Dwayne Evans led Ryukyu with 34 points on 12-for-15 shooting in a 92-75 triumph.</p>



<p>Toyama rebounded with a 97-74 victory in Game 2. Imamura was held to nine points.</p>



<p>But in Game 3 Imamura had another 27-point performance, this time converting 7 of 17 3-point shots as the hosts ended Toyama&#8217;s season. He led the team in scoring in the must-win game.</p>



<p>The Niigata Prefecture native averaged 9.8 points per game during the 2020-21 B. League season. He appeared in 56 games, making 21 starts. He started on May 9 in the Golden Kings&#8217; regular-season finale, his first start since January 3. His previous season-high point total was 22 on October 24 against the Shimane Susanoo Magic</p>



<p>When the playoffs opened up last weekend, the 25-year-old was called upon to provide a spark off the bench for a team that won 40 of 56 games in the regular season and captured the Western Conference crown.</p>



<p>After Ryukyu&#8217;s Game 1 win, Imamura said he was pleased with his performance and the team&#8217;s overall collective effort.</p>



<p>Reflecting on his big offensive outburst in a high-pressure game, Imamura said, &#8220;It was a different atmosphere than usual, but I think that what I have accumulated so far [this season] has come out as a good result.&#8221;<br></p>



<figure class="wp-block-gallery columns-1 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><noscript><img width="1024" height="683" src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066583-resized-1024x683.jpg" alt data-id="71055" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066583-resized-e1621601069170.jpg" data-link="https://japan-forward.com/photo_1066583-resized/" class="wp-image-71055"></noscript><img width="1024" height="683" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1024 683'%3E%3C/svg%3E" alt data-id="71055" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066583-resized-e1621601069170.jpg" data-link="https://japan-forward.com/photo_1066583-resized/" class="wp-image-71055 lazyload" data-src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066583-resized-1024x683.jpg"><figcaption class="blocks-gallery-item__caption">Keita Imamura averaged 9.8 points per game during the 2020-21 B. League season. (B. League)</figcaption></figure></li></ul></figure>



<p>In the series finale against the Grouses, Imamura canned a buzzer-beating 3-pointer to end the first quarter, giving the hosts a 22-20 lead. He had 11 points in the opening quarter in a tone-setting offensive performance for a team that often relies on Evans, center Jack Cooley and other veterans, including Ryuichi Kishimoto, Naoki Tashiro and Narito Namizato, to make things happen on offense.</p>



<p>Imamura had 19 points in the opening half.</p>



<p>Looking ahead to the playoff semifinals ー the Golden Kings play host to the Chiba in Game 1 on Saturday, May 22 ー Imamura said he hopes to continue to play a big role for the hosts.</p>



<p>&#8220;In the semifinal matchup against Chiba, I would like to continue to shoot aggressively and play aggressively so that I can attack the rim firmly and give energy to the team,&#8221; Imamura told reporters moments after his team eliminated the Grouses.</p>



<p>Game 2 of the Golden Kings-Jets series is on Sunday, May 23, and, if necessary, Game 3 is set for Monday, May 24. </p>



<p>(The other playoff semifinal showdown pits the Eastern Conference champion Utsunomiya Brex against the Kawasaki Brave Thunders. The Brex defeated the Brave Thunders 68-65 in Game 1 on Friday, May 21. Kawasaki trailed 42-30 at halftime. Makoto Hiejima led the hosts with 13 points, while Ryan Rossiter had eight points, 11 rebounds, 11 assists and three steals and Josh Scott contributed 18 points, nine boards and three steals. Jeff Gibbs also grabbed nine rebounds, helping the Brex outrebound the Brave Thunders 45-34. Nick Fazekas paced Kawasaki with 23 points and 11 rebounds and Ryusei Shinoyama scored 12 points. Game 2 is on May 22, with Game 3 penciled in on May 24.)<br><br></p>



<figure class="wp-block-gallery columns-1 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><noscript><img width="1024" height="683" src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1083361-1024x683.jpg" alt data-id="70978" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1083361-scaled-e1621521623586.jpg" data-link="https://japan-forward.com/photo_1083361/" class="wp-image-70978"></noscript><img width="1024" height="683" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1024 683'%3E%3C/svg%3E" alt data-id="70978" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1083361-scaled-e1621521623586.jpg" data-link="https://japan-forward.com/photo_1083361/" class="wp-image-70978 lazyload" data-src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1083361-1024x683.jpg"><figcaption class="blocks-gallery-item__caption">Keita Imamura is in his first season with the Ryukyu Golden Kings. (B. League)</figcaption></figure></li></ul></figure>



<h2><strong>Imamura’s Growth as a Player</strong></h2>



<p>A season ago, Imamura established himself as a dependable role player for the Niigata Albirex BB, averaging 10.9 points in 39 games. He scored a season-best 27 points against the Alvark Tokyo on February 16, 2020, and also had a pair of 26-point efforts.&nbsp;</p>



<p>The title-chasing Golden Kings signed Imamura during the offseason.</p>



<p>&#8220;I chose Okinawa, which has a special environment, because I felt that it was an environment where I could aim for higher heights as a basketball player, so I decided to come [here],&#8221; Imamura was quoted as saying in an interview posted on the Golden Kings website last August.</p>



<p>Longtime Ryukyu assistant coach Keith Richardson believes Imamura&#8217;s play during the 2019-20 season was an important stepping stone for him.</p>



<p>&#8220;What I saw in Keita really started last season while he was in Niigata, and I&#8217;ve watched him grow as a player this season,&#8221; Richardson told <strong>JAPAN Forward</strong> this week. &#8220;I felt in the right environment and with the right team he could and will become one of the best shooters/scorers in Japan.&#8221;<br></p>



<figure class="wp-block-gallery columns-1 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><noscript><img width="1024" height="683" src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1051309-resized-1024x683.jpg" alt data-id="71049" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1051309-resized.jpg" data-link="https://japan-forward.com/?attachment_id=71049" class="wp-image-71049"></noscript><img width="1024" height="683" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1024 683'%3E%3C/svg%3E" alt data-id="71049" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1051309-resized.jpg" data-link="https://japan-forward.com/?attachment_id=71049" class="wp-image-71049 lazyload" data-src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1051309-resized-1024x683.jpg"><figcaption class="blocks-gallery-item__caption">Keita Imamura wears the same jersey number as NBA sharpshooter Steph Curry. (B. League)</figcaption></figure></li></ul></figure>



<p>The 191-cm Imamura has a quick release on his shot. Strong footwork and good agility are noticeable attributes, too.</p>



<p>The Golden Kings recognize that Imamura has the skills to be a consistent scoring threat, according to Richardson.&nbsp;</p>



<p>&#8220;The team and his teammates help put him in the right situations on the floor for him to get good looks at the basket and he knocks them down,&#8221; Richardson said. &#8220;This has just increased his confidence in himself because his teammates trust him to make those shots.&#8221;</p>



<p>Trust from teammates breeds confidence, and Imamura is determined to become a better player.</p>



<p>&#8220;What&#8217;s really impressed me is watching him work on the more difficult shots like the floaters and the mid-range game because I think he knows he can&#8217;t be one-dimensional as a scorer,&#8221; Richardson observed.<br></p>



<figure class="wp-block-gallery columns-1 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><noscript><img width="1024" height="636" src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1024x636.jpg" alt data-id="71053" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767.jpg" data-link="https://japan-forward.com/?attachment_id=71053" class="wp-image-71053" srcset="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1024x636.jpg 1024w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-300x186.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-768x477.jpg 768w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1536x955.jpg 1536w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1320x820.jpg 1320w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-540x336.jpg 540w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767.jpg 1596w" sizes="(max-width: 1024px) 100vw, 1024px"></noscript><img width="1024" height="636" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1024 636'%3E%3C/svg%3E" alt data-id="71053" data-full-url="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767.jpg" data-link="https://japan-forward.com/?attachment_id=71053" class="wp-image-71053 lazyload" srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%201024%20636%22%3E%3C%2Fsvg%3E 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1024x636.jpg 1024w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-300x186.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-768x477.jpg 768w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1536x955.jpg 1536w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1320x820.jpg 1320w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-540x336.jpg 540w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767.jpg 1596w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1066562-resized-e1621600872767-1024x636.jpg"><figcaption class="blocks-gallery-item__caption">Imamura exhibits athleticism on the defensive end. (B. League)</figcaption></figure></li></ul></figure>



<p>The veteran coach noted that NBA superstar Steph Curry, who&#8217;s known for his great 3-point shooting ability, doesn&#8217;t only set up shop behind the arc. Instead, the Golden State Warriors icon keeps the defense guessing by utilizing a wide range of other well-crafted shots.</p>



<p>&#8220;When we watch Steph Curry play, his other abilities to score besides just shooting the catch-and-shoot 3, like making floaters, mid-range jumpers and even attacking the basket [are on display],&#8221; Richardson stated. &#8220;Keita has those characteristics that he is putting into his game.&#8221;</p>



<p>Indeed, that&#8217;s a sign of Imamura&#8217;s growth and maturation as a player.</p>



<p>&#8220;Look for big things from Keita going forward,&#8221; Richardson concluded.</p>



<p><br><br>Author:&nbsp; Ed Odeven<br></p>



<p><em>Follow Ed on JAPAN Forward&#8217;s </em><a href="https://japan-forward.com/?s=Japan+Sports+Notebook"><em>[Japan Sports Notebook] here</em></a><em> on Sundays,&nbsp; in </em><a href="https://japan-forward.com/?s=odds+and+evens"><em>[Odds and Evens] here</em></a><em> during the week, and Twitter </em><a href="https://twitter.com/ed_odeven"><em>＠ed_odeven.</em></a></p>



  
  
  <div class="
    mailpoet_form_popup_overlay
      "></div>
  <div id="mailpoet_form_3" class="
      mailpoet_form
      mailpoet_form_shortcode
      mailpoet_form_position_
      mailpoet_form_animation_
    ">
        <style type="text/css">.mailpoet_hp_email_label{display:none!important;}#mailpoet_form_3 .mailpoet_form {  }
#mailpoet_form_3 .mailpoet_paragraph { line-height: 20px; }
#mailpoet_form_3 .mailpoet_segment_label, #mailpoet_form_3 .mailpoet_text_label, #mailpoet_form_3 .mailpoet_textarea_label, #mailpoet_form_3 .mailpoet_select_label, #mailpoet_form_3 .mailpoet_radio_label, #mailpoet_form_3 .mailpoet_checkbox_label, #mailpoet_form_3 .mailpoet_list_label, #mailpoet_form_3 .mailpoet_date_label { display: block; font-weight: bold; }
#mailpoet_form_3 .mailpoet_text, #mailpoet_form_3 .mailpoet_textarea, #mailpoet_form_3 .mailpoet_select, #mailpoet_form_3 .mailpoet_date_month, #mailpoet_form_3 .mailpoet_date_day, #mailpoet_form_3 .mailpoet_date_year, #mailpoet_form_3 .mailpoet_date { display: block; }
#mailpoet_form_3 .mailpoet_text, #mailpoet_form_3 .mailpoet_textarea { width: 200px; }
#mailpoet_form_3 .mailpoet_checkbox {  }
#mailpoet_form_3 .mailpoet_submit input {  }
#mailpoet_form_3 .mailpoet_divider {  }
#mailpoet_form_3 .mailpoet_message {  }
#mailpoet_form_3 .mailpoet_validate_success { color: #468847; }
#mailpoet_form_3 .mailpoet_validate_error { color: #b94a48; }#mailpoet_form_3{;}#mailpoet_form_3 .mailpoet_message {margin: 0; padding: 0 20px;}#mailpoet_form_3 .mailpoet_paragraph.last {margin-bottom: 0} @media (max-width: 500px) {#mailpoet_form_3 {background-image: none;}} @media (min-width: 500px) {#mailpoet_form_3 .last .mailpoet_paragraph:last-child {margin-bottom: 0}}  @media (max-width: 500px) {#mailpoet_form_3 .mailpoet_form_column:last-child .mailpoet_paragraph:last-child {margin-bottom: 0}} </style>
    <form target="_self" method="post" action="https://japan-forward.com/wp-admin/admin-post.php?action=mailpoet_subscription_form" class="mailpoet_form mailpoet_form_form mailpoet_form_shortcode" novalidate data-delay data-exit-intent-enabled data-font-family>
      <input type="hidden" name="data[form_id]" value="3">
      <input type="hidden" name="token" value="0052d20703">
      <input type="hidden" name="api_version" value="v1">
      <input type="hidden" name="endpoint" value="subscribers">
      <input type="hidden" name="mailpoet_method" value="subscribe">

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"></label><div class="mailpoet_paragraph">Subscribe to Ed Odeven's weekly sports newsletter.</div>
<div class="mailpoet_paragraph"><label class="mailpoet_text_label" data-automation-id="form_first_name_label">First name <span class="mailpoet_required">*</span></label><input type="text" class="mailpoet_text" name="data[form_field_ZWIzYWJlNzQzZDM1X2ZpcnN0X25hbWU=]" title="First name" value data-automation-id="form_first_name" data-parsley-required="true" data-parsley-required-message="This field is required."></div>
<div class="mailpoet_paragraph"><label class="mailpoet_text_label" data-automation-id="form_last_name_label">Last name <span class="mailpoet_required">*</span></label><input type="text" class="mailpoet_text" name="data[form_field_ODkwOGQzMDIxNzA3X2xhc3RfbmFtZQ==]" title="Last name" value data-automation-id="form_last_name" data-parsley-required="true" data-parsley-required-message="This field is required."></div>
<div class="mailpoet_paragraph"><label class="mailpoet_text_label" data-automation-id="form_email_label">Email <span class="mailpoet_required">*</span></label><input type="email" class="mailpoet_text" name="data[form_field_ZDg1N2Y4ZTUxNzRiX2VtYWls]" title="Email" value data-automation-id="form_email" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."></div>
<div class="mailpoet_paragraph"><label class="mailpoet_segment_label">Select:</label><label class="mailpoet_checkbox_label"><input type="checkbox" class="mailpoet_checkbox" name="data[form_field_MDZiNzIyZjhmNzc5X3NlZ21lbnRz][]" value="10" checked="checked" data-parsley-required="true" data-parsley-group="segments" data-parsley-errors-container=".mailpoet_error_segments" data-parsley-required-message="Please select a list"> Sports News with Ed Odeven</label><span class="mailpoet_error_segments"></span></div>
<div class="mailpoet_recaptcha" data-sitekey="6Lc_f0wUAAAAAIe5Ps94jqyuY3ta3qzBVJs3BHU5">
      <div class="mailpoet_recaptcha_container"></div>
      <noscript>
        <div>
          <div style="width: 302px; height: 422px; position: relative;">
            <div style="width: 302px; height: 422px; position: absolute;">
              <iframe src="https://www.google.com/recaptcha/api/fallback?k=6Lc_f0wUAAAAAIe5Ps94jqyuY3ta3qzBVJs3BHU5" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;">
              </iframe>
            </div>
          </div>
          <div style="width: 300px; height: 60px; border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px;">
            <textarea id="g-recaptcha-response" name="data[recaptcha]" class="g-recaptcha-response" style="width: 250px; height: 40px; border: 1px solid #c1c1c1; margin: 10px 25px; padding: 0px; resize: none;">
            </textarea>
          </div>
        </div>
      </noscript>
      <input class="mailpoet_recaptcha_field" type="hidden" name="recaptcha">
    </div><div class="mailpoet_paragraph"><input type="submit" class="mailpoet_submit" value="Subscribe!" data-automation-id="subscribe-submit-button" style="border-color:transparent;"><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success" style="display:none;">Thanks for signing up! Check your inbox or spam folder to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error" style="display:none;">        </p>
      </div>
    </form>
  </div>

  



<p></p>

</div></div><div class="theiaPostSlider_footer _footer"></div><p><!-- END THEIA POST SLIDER --></p><div class="jf-bottom-article" style="text-align: center; " id="jf-396575937"><div style="margin-bottom:8px;"><a href="https://japan-forward.com/reach-out-to-north-korea/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'international-partners-2'});">
	<noscript><img src="https://japan-forward.com/wp-content/uploads/2021/02/reach-out-to-north-korea-banner.jpg" alt="Japan, International Partners Seek Return of Abductees" style="vertical-align:bottom" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'international-partners-2'});"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Japan, International Partners Seek Return of Abductees" style="vertical-align:bottom" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'international-partners-2'});" data-src="https://japan-forward.com/wp-content/uploads/2021/02/reach-out-to-north-korea-banner.jpg" class=" lazyload"></a></div><div style="margin-bottom:8px;"><a href="https://japan-forward.com/japan-international-partners/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'international-partners'});">
	<noscript><img src="https://japan-forward.com/wp-content/uploads/2020/12/japan-international-partners-rectangle.jpg" alt="Japan, International Partners Seek Return of Abductees" style="vertical-align:bottom" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'international-partners'});"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Japan, International Partners Seek Return of Abductees" style="vertical-align:bottom" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'international-partners'});" data-src="https://japan-forward.com/wp-content/uploads/2020/12/japan-international-partners-rectangle.jpg" class=" lazyload"></a></div></div><div class="jf-outbrain" style="margin-left: auto; margin-right: auto; text-align: center; " id="jf-1579203611"><!-- outbrain ad -->
<div class="OUTBRAIN" data-src="https://japan-forward.com/rika-kihira-japanese-prodigy-wins-figure-skating-grand-prix-final-in-debut-season/" data-widget-id="AR_1"></div>

<div class="OUTBRAIN" data-src="https://japan-forward.com/rika-kihira-japanese-prodigy-wins-figure-skating-grand-prix-final-in-debut-season/" data-widget-id="AR_2"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
<!-- outbrain ad --></div><div data-theia-post-slider-options='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_71044&quot;,&quot;nav&quot;:&quot;.theiaPostSlider_nav&quot;,&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your &amp;leftarrow; &amp;rightarrow; (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;font&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/japan-forward.com\/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama\/&quot;,&quot;postId&quot;:71044,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/japan-forward.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;],&quot;prevFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-arrow-left-023\&quot;&gt;&lt;\/span&gt;&quot;,&quot;nextFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-arrow-right-023\&quot;&gt;&lt;\/span&gt;&quot;}'
					 data-theia-post-slider-on-change-slide='&quot;&quot;'></div>																											</div><!--mvp-content-main-->
																																																										<div class="mvp-alp-soc-reg left relative">
							<div class="mvp-alp-soc-wrap">
					<ul class="mvp-alp-soc-list">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/&amp;t=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
							<li class="mvp-alp-soc-fb"><span class="fa fa-facebook"></span></li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama &amp;url=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
							<li class="mvp-alp-soc-twit"><span class="fa fa-twitter"></span></li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/&amp;media=https://japan-forward.com/wp-content/uploads/2021/05/RGK.Imamura1-590x354.jpg&amp;description=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="mvp-alp-soc-pin"><span class="fa fa-pinterest-p"></span></li>
						</a>
						<a href="mailto:?subject=BASKETBALL | Ryukyu’s Keita Imamura Showcases Talent with Pair of High-Scoring Games Against Toyama&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://japan-forward.com/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/">
							<li class="mvp-alp-soc-com"><span class="fa fa-envelope"></span></li>
						</a>
					</ul>
				</div>
</div>
																																																							<div id="mvp-content-bot" class="left">
																												<div class="mvp-post-tags">
															<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="https://japan-forward.com/tag/b-league-2/" rel="tag">B. League</a><a href="https://japan-forward.com/tag/basketball/" rel="tag">basketball</a><a href="https://japan-forward.com/tag/chiba-jets/" rel="tag">Chiba Jets</a><a href="https://japan-forward.com/tag/ed-odeven/" rel="tag">Ed Odeven</a><a href="https://japan-forward.com/tag/keita-imamura/" rel="tag">Keita Imamura</a><a href="https://japan-forward.com/tag/keith-richardson/" rel="tag">Keith Richardson</a><a href="https://japan-forward.com/tag/niigata-albirex-bb/" rel="tag">Niigata Albirex BB</a><a href="https://japan-forward.com/tag/ryukyu-golden-kings/" rel="tag">Ryukyu Golden Kings</a><a href="https://japan-forward.com/tag/steph-curry/" rel="tag">steph curry</a><a href="https://japan-forward.com/tag/toyama-grouses/" rel="tag">Toyama Grouses</a></span>
														</div><!--mvp-post-tags-->
														<div class="posts-nav-link">
																													</div><!--posts-nav-link-->
																																											<div id="mvp-author-box-wrap" class="left relative">
																<div class="mvp-author-box-out right relative">
																	<div id="mvp-author-box-img" class="left relative">
																		<noscript><img src="https://japan-forward.com/wp-content/uploads/2020/05/ed-odeven-japan-forward-100x100.jpg" width="60" height="60" alt="Ed Odeven" class="avatar avatar-60 wp-user-avatar wp-user-avatar-60 alignnone photo"></noscript><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 60 60'%3E%3C/svg%3E" width="60" height="60" alt="Ed Odeven" class="avatar avatar-60 wp-user-avatar wp-user-avatar-60 alignnone photo lazyload" data-src="https://japan-forward.com/wp-content/uploads/2020/05/ed-odeven-japan-forward-100x100.jpg">																	</div><!--mvp-author-box-img-->
																	<div class="mvp-author-box-in">
																		<div id="mvp-author-box-head" class="left relative">
																			<span class="mvp-author-box-name left relative"><a href="https://japan-forward.com/author/ed-odeven/" title="Posts by Ed Odeven" rel="author">Ed Odeven</a></span>
																			<div id="mvp-author-box-soc-wrap" class="left relative">
																																																													<a href="https://m.facebook.com/Ed-Odeven-Reporting-622578864548599/?ref=bookmarks" alt="Facebook" target="_blank"><span class="mvp-author-box-soc fa fa-facebook-square fa-2"></span></a>
																																																													<a href="https://twitter.com/ed_odeven" alt="Twitter" target="_blank"><span class="mvp-author-box-soc fa fa-twitter-square fa-2"></span></a>
																																																																																																					<a href="https://instagram.com/readytowritenow" alt="Instagram" target="_blank"><span class="mvp-author-box-soc fa fa-instagram fa-2"></span></a>
																																																											</div><!--mvp-author-box-soc-wrap-->
																		</div><!--mvp-author-box-head-->
																	</div><!--mvp-author-box-in-->
																</div><!--mvp-author-box-out-->
																<div id="mvp-author-box-text" class="left relative">
																	<p>Ed Odeven is a longtime sports journalist who previously worked for The Japan Times as its chief basketball reporter for nearly 14 years. He also covered a wide range of other sports for the newspaper, including at the 2008 Beijing Olympics and 2012 London Games. A graduate of Arizona State University, Odeven worked for several newspapers in the Grand Canyon State before moving to Japan. He has freelanced for dozens of media outlets around the world.</p>
																</div><!--mvp-author-box-text-->
															</div><!--mvp-author-box-wrap-->
																												<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
															<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																																	<img src="https://japan-forward.com/wp-content/uploads/2020/11/japan_forward_logo-box-top.png"/>
																	<meta itemprop="url" content="https://japan-forward.com/wp-content/uploads/2020/11/japan_forward_logo-box-top.png">
																															</div><!--mvp-org-logo-->
															<meta itemprop="name" content="JAPAN Forward">
														</div><!--mvp-org-wrap-->
													</div><!--mvp-content-bot-->
												</div><!--mvp-content-body-top-->
												<div class="mvp-cont-read-wrap">
																											<div class="mvp-cont-read-but-wrap left relative">
															<span class="mvp-cont-read-but">Continue Reading</span>
														</div><!--mvp-cont-read-but-wrap-->
																																																					<div id="mvp-related-posts" class="left relative">
															<h4 class="mvp-widget-home-title">
																<span class="mvp-widget-home-title">You may like</span>
															</h4>
																			<ul class="mvp-related-posts-list left related">
            								<a href="https://japan-forward.com/odds-and-evens-reigning-indy-500-champion-takuma-sato-chases-history-in-pursuit-of-another-title/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<noscript><img width="400" height="240" src="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-400x240.jpg" class="mvp-reg-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px"></noscript><img width="400" height="240" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 400 240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%20400%20240%22%3E%3C%2Fsvg%3E 400w" sizes="(max-width: 400px) 100vw, 400px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-590x354.jpg 590w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-400x240.jpg">									<noscript><img width="80" height="80" src="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-80x80.jpg" class="mvp-mob-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-120x120.jpg 120w" sizes="(max-width: 80px) 100vw, 80px"></noscript><img width="80" height="80" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 80 80'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%2080%2080%22%3E%3C%2Fsvg%3E 80w" sizes="(max-width: 80px) 100vw, 80px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/Indy3-120x120.jpg 120w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/Indy3-80x80.jpg">																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>[ODDS and EVENS] Reigning Indy 500 Champion Takuma Sato Chases History in Pursuit of Another Title</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="https://japan-forward.com/horse-racing-gran-alegria-dominates-down-the-stretch-for-runaway-victory-in-victoria-mile/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<noscript><img width="400" height="240" src="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-400x240.jpg" class="mvp-reg-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px"></noscript><img width="400" height="240" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 400 240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%20400%20240%22%3E%3C%2Fsvg%3E 400w" sizes="(max-width: 400px) 100vw, 400px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-590x354.jpg 590w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-400x240.jpg">									<noscript><img width="80" height="80" src="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-80x80.jpg" class="mvp-mob-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-120x120.jpg 120w" sizes="(max-width: 80px) 100vw, 80px"></noscript><img width="80" height="80" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 80 80'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%2080%2080%22%3E%3C%2Fsvg%3E 80w" sizes="(max-width: 80px) 100vw, 80px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/CL.516-120x120.jpg 120w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/CL.516-80x80.jpg">																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>HORSE RACING | Gran Alegria Dominates Down the Stretch for Runaway Victory in Victoria Mile</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="https://japan-forward.com/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<noscript><img width="400" height="240" src="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-400x240.jpg" class="mvp-reg-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px"></noscript><img width="400" height="240" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 400 240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%20400%20240%22%3E%3C%2Fsvg%3E 400w" sizes="(max-width: 400px) 100vw, 400px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-590x354.jpg 590w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-400x240.jpg">									<noscript><img width="80" height="80" src="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-80x80.jpg" class="mvp-mob-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-120x120.jpg 120w" sizes="(max-width: 80px) 100vw, 80px"></noscript><img width="80" height="80" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 80 80'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%2080%2080%22%3E%3C%2Fsvg%3E 80w" sizes="(max-width: 80px) 100vw, 80px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-120x120.jpg 120w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/japan-sports-notebook-antlers-end-marinos-11-match-unbeaten-streak-80x80.jpg">																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>[JAPAN SPORTS NOTEBOOK] Antlers End Marinos’ 11-Match Unbeaten Streak</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="https://japan-forward.com/basketball-utsunomiya-brex-begin-quest-to-capture-b-league-title-as-playoffs-tip-off/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<noscript><img width="400" height="240" src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-400x240.jpg" class="mvp-reg-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px"></noscript><img width="400" height="240" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 400 240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%20400%20240%22%3E%3C%2Fsvg%3E 400w" sizes="(max-width: 400px) 100vw, 400px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-590x354.jpg 590w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-400x240.jpg">									<noscript><img width="80" height="80" src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-80x80.jpg" class="mvp-mob-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-120x120.jpg 120w" sizes="(max-width: 80px) 100vw, 80px"></noscript><img width="80" height="80" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 80 80'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%2080%2080%22%3E%3C%2Fsvg%3E 80w" sizes="(max-width: 80px) 100vw, 80px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-120x120.jpg 120w" data-src="https://japan-forward.com/wp-content/uploads/2021/05/photo_1068313-resized-80x80.jpg">																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>BASKETBALL | Utsunomiya Brex Begin Quest to Capture B. League Title as Playoffs Tip Off</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            								<a href="https://japan-forward.com/odds-and-evens-olympians-caught-in-rhetorical-crossfire-over-plans-to-hold-tokyo-games/" rel="bookmark">
            			<li>
							                				<div class="mvp-related-img left relative">
									<noscript><img width="400" height="240" src="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-400x240.jpg" class="mvp-reg-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px"></noscript><img width="400" height="240" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 400 240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%20400%20240%22%3E%3C%2Fsvg%3E 400w" sizes="(max-width: 400px) 100vw, 400px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-400x240.jpg 400w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-1000x600.jpg 1000w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-590x354.jpg 590w" data-src="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-400x240.jpg">									<noscript><img width="80" height="80" src="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-80x80.jpg" class="mvp-mob-img wp-post-image" alt srcset="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-120x120.jpg 120w" sizes="(max-width: 80px) 100vw, 80px"></noscript><img width="80" height="80" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 80 80'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image lazyload" alt srcset="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20viewBox%3D%220%200%2080%2080%22%3E%3C%2Fsvg%3E 80w" sizes="(max-width: 80px) 100vw, 80px" data-srcset="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-80x80.jpg 80w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-300x300.jpg 300w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-150x150.jpg 150w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-160x160.jpg 160w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-100x100.jpg 100w, https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-120x120.jpg 120w" data-src="https://japan-forward.com/wp-content/uploads/2021/04/Swimming-Rikako-Ikee-001-80x80.jpg">																	</div><!--mvp-related-img-->
														<div class="mvp-related-text left relative">
								<p>[ODDS and EVENS] Olympians Caught in Rhetorical Crossfire Over Plans to Hold Tokyo Games</p>
							</div><!--mvp-related-text-->
            			</li>
						</a>
            		</ul>														</div><!--mvp-related-posts-->
																																																																						<div id="mvp-comments-button" class="left relative mvp-com-click-71044 mvp-com-but-71044">
																<span class="mvp-comment-but-text">Click to comment</span>
															</div><!--mvp-comments-button-->
															<div id="comments" class="mvp-com-click-id-71044 mvp-com-click-main">
						<p>
			You must be logged in to post a comment			<a href="https://japan-forward.com/wp-login.php?redirect_to=https%3A%2F%2Fjapan-forward.com%2Fbasketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama%2F">
				Login			</a>
		</p>
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/basketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://japan-forward.com/jplogin0211/?redirect_to=https%3A%2F%2Fjapan-forward.com%2Fbasketball-ryukyus-keita-imamura-showcases-talent-with-pair-of-high-scoring-games-against-toyama%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!--comments-->																																							</div><!--mvp-cont-read-wrap-->
											</div><!--mvp-content-body-->
								</div><!--mvp-content-wrap-->
							</div><!--mvp-post-content-->
				</div><!--mvp-post-main-->
		</div><!--mvp-article-cont-->
				
    <script type="text/javascript">
	jQuery(document).ready(function($) {
  	  $(".mvp-com-click-71044").on("click", function(){
  	    $(".mvp-com-click-id-71044").show();
	    $(".mvp-disqus-thread-71044").show();
  	    $(".mvp-com-but-71044").hide();
	  });
	});
    </script>	</article><!--mvp-article-wrap-->
	</div><!--mvp-auto-post-main-->
			<div id="mvp-side-wrap" class="left relative theiaStickySidebar">
						<section class="mvp-side-widget jf-widget"><div style="margin-bottom:8px;"><a href="https://japan-forward.com/japan-international-partners/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'international-partners-sidebar'});">
	<img src="https://japan-forward.com/wp-content/uploads/2020/12/japan-international-partners-rectangle.jpg" alt="Japan, International Partners Seek Return of Abductees" style="vertical-align:bottom" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'international-partners-sidebar'});" ></a></div></section><section class="mvp-side-widget jf-widget"><div style="margin-bottom:8px;"><a href="https://japan-forward.com/reach-out-to-north-korea/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'international-partners-2'});">
	<img src="https://japan-forward.com/wp-content/uploads/2021/02/reach-out-to-north-korea-banner.jpg" alt="Japan, International Partners Seek Return of Abductees" style="vertical-align:bottom" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'international-partners-2'});" ></a></div></section><section class="mvp-side-widget jf-widget"><div style="margin-bottom:8px;"><a href="https://japan-forward.com/tokyo-during-covid-19-green-space-rise-of-telework-bring-new-lifestyle-opportunities/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-sidebar-2'});">
<img src="https://japan-forward.com/wp-content/uploads/2021/01/tokyo-wfh-Side_C.jpg" alt="Tokyo During COVID-19: Green Space, Rise of Telework Bring New Lifestyle Opportunities" width="100%"  onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'Tokyo-metro-WFH-sidebar-2'});"></a></div></section><section class="mvp-side-widget jf-widget"><div style="margin-bottom:8px;"><a href="https://japan-forward.com/3-11-earthquake-rebuilding-10-years-later-tohokus-recovery-and-resilience-together-with-the-world" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': '3-11-mofa-side-banner'});">
<img src="https://japan-forward.com/wp-content/uploads/2021/03/3-11-earthquake-rebuilding-10-years-later-tohokus-recovery-and-resilience-together-with-the-world-side-banner.jpg" alt="[3.11 Earthquake: Rebuilding] 10 Years Later: Tohoku’s Recovery and Resilience Together with the World
" width="100%"  onload="gtag('event', 'impression', {'event_category': 'banner','event_label': '3-11-mofa-side-banner'});"></a></div></section><section class="mvp-side-widget jf-widget"><div style="margin-bottom:8px;"><a href="https://japan-forward.com/innovators-in-japan-are-developing-new-technologies-to-counter-coronavirus/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'innovators-mofa-side-banner'});">
<img src="https://japan-forward.com/wp-content/uploads/2021/03/innovators-in-japan-are-developing-new-technologies-to-counter-coronavirus-side.jpg" alt="Innovators in Japan are Developing New Technologies to Counter Coronavirus" width="100%"  onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'innovators-side-banner'});"></a></div></section><section class="mvp-side-widget jf-widget"><a href="https://featured.japan-forward.com/whalingtoday/" target="_blank" onclick="gtag('event', 'click', {'event_category': 'banner','event_label': 'whaling-today'});">
	<img src="https://japan-forward.com/wp-content/uploads/2020/11/whaling-today-ukiyoe_2.jpg" alt="Whaling Today" width="336px" onload="gtag('event', 'impression', {'event_category': 'banner','event_label': 'whaling-today'});"></a>
</section><section class="mvp-side-widget jf-widget"><div style="margin-left: auto; margin-right: auto; text-align: center; " id="jf-2064032946"><a href="https://grapee.jp/en/" target="_blank" onclick="ga('send','event','banner','click','grape_japan');">
<img src="https://japan-forward.com/wp-content/uploads/2020/11/grape.jpg" alt="grape Japan" width="336px" onload="ga('send','event','banner','impression','grape_japan');" ></div></section><section id="custom_html-2" class="widget_text mvp-side-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="https://open.spotify.com/embed-podcast/show/0uNL7IujuwJ2ODneRl5yEL" width="100%" height="232" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe></div></section>			</div><!--mvp-side-wrap-->	</div><!--mvp-auto-post-grid-->
</div><!--mvp-main-box-->			</div><!--mvp-main-body-wrap-->
			<footer id="mvp-foot-wrap" class="left relative">
				<div id="mvp-foot-top" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-logo" class="left relative">
															<a href="https://japan-forward.com/"><img src="https://japan-forward.com/wp-content/uploads/2020/11/japan_forward_logo-box-top.png" alt="JAPAN Forward" data-rjs="2" /></a>
													</div><!--mvp-foot-logo-->
						<div id="mvp-foot-soc" class="left relative">
							<ul class="mvp-foot-soc-list left relative">
																	<li><a href="https://www.facebook.com/japanforward" target="_blank" class="fa fa-facebook fa-2"></a></li>
																									<li><a href="https://www.twitter.com/itsjapanforward" target="_blank" class="fa fa-twitter fa-2"></a></li>
																																	<li><a href="https://www.instagram.com/japanforward" target="_blank" class="fa fa-instagram fa-2"></a></li>
																																	<li><a href="https://www.youtube.com/japan-forward" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
																									<li><a href="https://www.linkedin.com/company/japan-forward/" target="_blank" class="fa fa-linkedin fa-2"></a></li>
																							</ul>
						</div><!--mvp-foot-soc-->
						<div id="mvp-foot-menu-wrap" class="left relative">
							<div id="mvp-foot-menu" class="left relative">
								<div class="menu-footer-menu-2-container"><ul id="menu-footer-menu-2" class="menu"><li id="menu-item-10813" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10813"><a href="https://japan-forward.com/subscribe-to-japan-forwards-mail-service/">Email Subscription</a></li>
<li id="menu-item-53710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53710"><a href="https://japan-forward.com/subscribe-to-podcast/">Subscribe to Podcast</a></li>
<li id="menu-item-20431" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20431"><a href="https://japan-forward.com/about-japan-forward/">About JAPAN Forward</a></li>
<li id="menu-item-10574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10574"><a href="https://japan-forward.com/message-from-editor-in-chief/">Message from Editor in Chief</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="https://japan-forward.com/contact-us/">Contact us</a></li>
<li id="menu-item-10575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10575"><a href="https://japan-forward.com/writers/">Writers</a></li>
<li id="menu-item-10576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10576"><a href="https://japan-forward.com/jobs/">Jobs</a></li>
<li id="menu-item-57782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57782"><a href="https://japan-forward.com/about-japan-forward-jp/supporter/">会員について</a></li>
</ul></div>							</div><!--mvp-foot-menu-->
						</div><!--mvp-foot-menu-wrap-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-top-->
				<div id="mvp-foot-bot" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © 2020 JAPAN Forward.</p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-bot-->
			</footer>
		</div><!--mvp-site-main-->
	</div><!--mvp-site-wall-->
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
		<div data-theiaStickySidebar-sidebarSelector='"#mvp-side-wrap"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":120,"additionalMarginBottom":20,"updateSidebarHeight":true,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		    <!-- Facebook Pixel Event Code -->
    <script type='text/javascript'>
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script>
    <!-- End Facebook Pixel Event Code -->
    <div id='fb-pxl-ajax-code'></div>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})()
	</script>
			<!-- Root element of PhotoSwipe. Must have class pswp. -->
		<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

		    <!-- Background of PhotoSwipe.
		         It's a separate element as animating opacity is faster than rgba(). -->
		    <div class="pswp__bg"></div>

		    <!-- Slides wrapper with overflow:hidden. -->
		    <div class="pswp__scroll-wrap">

		        <!-- Container that holds slides.
		            PhotoSwipe keeps only 3 of them in the DOM to save memory.
		            Don't modify these 3 pswp__item elements, data is added later on. -->
		        <div class="pswp__container">
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		        </div>

		        <!-- Default (PhotoSwipeUI_Default) interface on top of sliding area. Can be changed. -->
		        <div class="pswp__ui pswp__ui--hidden">

		            <div class="pswp__top-bar">

		                <!--  Controls are self-explanatory. Order can be changed. -->

		                <div class="pswp__counter"></div>

		                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>

		                <button class="pswp__button pswp__button--share" title="Share"></button>

		                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>

		                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>

		                <!-- Preloader demo http://codepen.io/dimsemenov/pen/yyBWoR -->
		                <!-- element will get class pswp__preloader-active when preloader is running -->
		                <div class="pswp__preloader">
		                    <div class="pswp__preloader__icn">
		                      <div class="pswp__preloader__cut">
		                        <div class="pswp__preloader__donut"></div>
		                      </div>
		                    </div>
		                </div>
		            </div>

		            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
		                <div class="pswp__share-tooltip"></div>
		            </div>

		            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
		            </button>

		            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
		            </button>

		            <div class="pswp__caption">
		                <div class="pswp__caption__center"></div>
		            </div>

		        </div>

		    </div>

		</div>
		<link rel='stylesheet' id='mailpoet_public-css'  href='https://japan-forward.com/wp-content/plugins/mailpoet/assets/dist/css/mailpoet-public.dd713c66.css?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mailpoet_custom_fonts_css-css'  href='https://fonts.googleapis.com/css?family=Abril+FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya+Sans%3A400%2C400i%2C700%2C700i%7CAmatic+SC%3A400%2C400i%2C700%2C700i%7CAnonymous+Pro%3A400%2C400i%2C700%2C700i%7CArchitects+Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo+Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert+One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson+Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo+2%3A400%2C400i%2C700%2C700i%7CFira+Sans%3A400%2C400i%2C700%2C700i%7CFjalla+One%3A400%2C400i%2C700%2C700i%7CFrank+Ruhl+Libre%3A400%2C400i%2C700%2C700i%7CGreat+Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM+Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie+Flower%3A400%2C400i%2C700%2C700i%7CInknut+Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre+Baskerville%3A400%2C400i%2C700%2C700i%7CLibre+Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing+You+Could+Do%3A400%2C400i%2C700%2C700i%7CNoto+Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld+Standard+TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza+Libre%3A400%2C400i%2C700%2C700i%7CPT+Sans%3A400%2C400i%2C700%2C700i%7CPT+Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie+Beanie%3A400%2C400i%2C700%2C700i%7CRoboto+Slab%3A400%2C400i%2C700%2C700i%7CRopa+Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows+Into+Light%3A400%2C400i%2C700%2C700i%7CSpace+Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue+Ellen+Francisco%3A400%2C400i%2C700%2C700i%7CTitillium+Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork+Sans%3A400%2C400i%2C700%2C700i%7CYatra+One%3A400%2C400i%2C700%2C700i&#038;ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' type='text/css' media='all' />
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/japan-forward.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/theia-post-slider-premium/dist/js/hammer.min.js?ver=2.0.4' id='hammer.js-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/theia-post-slider-premium/dist/js/theia-post-slider.js?ver=2.6.0' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/japan-forward.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=4.8.0' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=4.8.0' id='woocommerce-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_d94b24c09ffd3b63162ecdc859b959a4","fragment_name":"wc_fragments_d94b24c09ffd3b63162ecdc859b959a4","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=4.8.0' id='wc-cart-fragments-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/zox-alp//scripts/jquery.sticky-kit.min.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/zox-alp//scripts/jquery.waypoints.min.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='jquery-waypoints-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.2' id='reviewer-nouislider-plugin-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.2' id='reviewer-photoswipe-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.2' id='reviewer-knob-plugin-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.2' id='reviewer-public-script-js'></script>
<script type='text/javascript' id='reviewer-reviews-boxes-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"53d9262fc9","ajax_url":"https:\/\/japan-forward.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"9ebcd18800","ajax_url":"https:\/\/japan-forward.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"9173116243","ajax_url":"https:\/\/japan-forward.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.2' id='reviewer-reviews-boxes-script-js'></script>
<script type='text/javascript' id='reviewer-widget-users-reviews-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"ee92c098fd","ajax_url":"https:\/\/japan-forward.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.2' id='reviewer-widget-users-reviews-script-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/themes/zox-news/js/mvpcustom.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='mvp-custom-js'></script>
<script type='text/javascript' id='mvp-custom-js-after'>

	jQuery(document).ready(function($) {
	$(window).load(function(){
	var leaderHeight = $("#mvp-leader-wrap").outerHeight();
	var logoHeight = $("#mvp-main-nav-top").outerHeight();
	var botHeight = $("#mvp-main-nav-bot").outerHeight();
	var navHeight = $("#mvp-main-head-wrap").outerHeight();
	var headerHeight = navHeight + leaderHeight;
	var aboveNav = leaderHeight + logoHeight;
	var totalHeight = logoHeight + botHeight;
	var previousScroll = 0;
	$(window).scroll(function(event){
			var scroll = $(this).scrollTop();
			if ($(window).scrollTop() > aboveNav){
				$("#mvp-main-nav-top").addClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top", logoHeight );
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top","0");
			}
			if ($(window).scrollTop() > headerHeight){
				$("#mvp-main-nav-top").addClass("mvp-fixed");
				$("#mvp-main-nav-bot").addClass("mvp-fixed1");
				$("#mvp-main-body-wrap").css("margin-top", totalHeight );
				$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
				$(".mvp-fly-top").addClass("mvp-to-top");
	    		if(scroll < previousScroll) {
					$("#mvp-main-nav-bot").addClass("mvp-fixed2");
					$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
				} else {
					$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
					$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
				}
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-fixed");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed1");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
				$("#mvp-main-body-wrap").css("margin-top","0");
				$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
			}
			previousScroll = scroll;
	});
	
	$(".mvp-alp-side-in").niceScroll({cursorcolor:"#ccc",cursorwidth: 5,cursorborder: 0,zindex:999999});
	
	});
	});
	

	jQuery(document).ready(function($) {
	// Mobile Social Buttons More
	$(window).load(function(){
 		$(".mvp-soc-mob-right").on("click", function(){
			$("#mvp-soc-mob-wrap").toggleClass("mvp-soc-mob-more");
  		});
  	});
	});
  	

	jQuery(document).ready(function($) {
	// Continue Reading Button
	$(window).load(function(){
 		$(".mvp-cont-read-but").on("click", function(){
			$("#mvp-content-body-top").css("max-height","none");
			$("#mvp-content-body-top").css("overflow","visible");
			$(".mvp-cont-read-but-wrap").hide();
  		});
  	});
	});
  	

	jQuery(document).ready(function($) {
	$(window).load(function(){
		var leaderHeight = $("#mvp-leader-wrap").outerHeight();
		$("#mvp-site-main").css("margin-top", leaderHeight );
  	});

	$(window).resize(function(){
		var leaderHeight = $("#mvp-leader-wrap").outerHeight();
		$("#mvp-site-main").css("margin-top", leaderHeight );
	});

	});
  	

	jQuery(document).ready(function($) {
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});
	
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/themes/zox-news/js/scripts.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='zoxnews-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/themes/zox-news/js/retina.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='retina-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/woocommerce/assets/js/flexslider/jquery.flexslider.min.js?ver=2.7.2' id='flexslider-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/themes/zox-news/js/jquery.infinitescroll.min.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='infinitescroll-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/themes/zox-news/js/alp.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='alp-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-includes/js/comment-reply.min.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='comment-reply-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/lazy-loading-responsive-images/js/lazysizes.min.js?ver=1608275340' id='lazysizes-js'></script>
<script type='text/javascript' src='https://japan-forward.com/wp-includes/js/wp-embed.min.js?ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='wp-embed-js'></script>
<script type='text/javascript' id='mailpoet_public-js-extra'>
/* <![CDATA[ */
var MailPoetForm = {"ajax_url":"https:\/\/japan-forward.com\/wp-admin\/admin-ajax.php","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://japan-forward.com/wp-content/plugins/mailpoet/assets/dist/js/public.27bd06f0.js?ver=3.56.1' id='mailpoet_public-js'></script>
<script type='text/javascript' id='mailpoet_public-js-after'>
function initMailpoetTranslation() {
  if (typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=reCaptchaCallback&#038;render=explicit&#038;ver=f84f1b9e18d2d1e446e994d3d5fb8c7a' id='mailpoet_recaptcha-js'></script>
</body>
</html><!-- WP Fastest Cache file was created in 0.25093698501587 seconds, on 22-05-21 11:25:52 --><!-- via php -->